Max et le Min d’un tableau

Un algorithme qui permet d’afficher le plus grand (max) et le plus petit élément (min) d’un tableau:


Algorithme MinMax;
	
Var
	T: tab[1..n]: entier;
	min, max, i: entier;
	
Debut
	
	min := T[1];
	max := T[1];
	
	Pour i := 2 à n Faire:
		Si (T[i] < min) Alors
			min := T[i];
		Sinon Si (T[i] > max) Alors
			max := T[i];
		FinSi
	FinPour
	
	Ecrire("Le min est: ", min);
	Ecrire("Le max est: ", max);
	
Fin

About these ads

4 commentaires

  1. Bonjour,

    Des optimisations peuvent être faites quand dans le as de certaines données.
    Si par exemple il y a plusieurs fois la valeur minimale dans le tableau, remplacer "Si (T[i] < min)" par "Si (T[i] <= min)" évite quelques controles inutiles sur la valeur maxi.

    1. Dans le cas, il ya plusieurs valeurs de min (resp. max), on peux avoir la 1re valeur du min (resp. max) par i := n + 1; (casser la boucle), sinon on va voir la dernier valeur.
      Ou bien, on peut stocker dans un autre tableau les indices du min (resp. max) et le nombre du min (resp. max) dans le tableau est le longue de ce tableau.

  2. Merci pour votre explication, mais dites nous svp, dans le cas ou n ne sera connu d’avance c’est a dire le nombre d’element saisir dans le tableau est inconnu que ferions nous? merci davance!

    1. Quand on déclare un tableau on doit savoir sa taille, c’est statique.
      Pour cela y a les listes, une liste est dynamique.

Laisser des commentaires:

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

Suivre

Recevez les nouvelles publications par mail.

%d bloggers like this: