Le Max et le Min d’une série des nombres introduit par le clavier se termine par 0

Un algorithme qui permet de calculer le Max et le Min d’une série des nombres introduit par le clavier se termine par 0:


Algorithmique Max_Min;

Var	
	n, Max, Min: entier;

Debut
	Max := 0;
	Min := 0;
	Lire(n);

	TantQue (n <> 0) Faire
		Si (n > Max) Alors
			Max := n;
		Sinon
			Min := n;
		FinSi
		Lire(n);
	FinTantQue

	Ecrire("Le Max est: ", Max);
	Ecrire("Le Min est: ", Min);
Fin

Laisser des commentaires:

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :