Le nombre des nombres positifs et négatifs d’une série des nombres introduit par le clavier se termine par 0

Un algorithme qui permet de calculer le nombre des nombres positifs et négatifs d’une série des nombres introduit par le clavier se termine par 0:


Algorithmique Pos_Neg;

Var	
	n, Positif, Negatif: entier;

Debut
	Positif := 0;
	Negatif := 0;
	Lire(n);

	TantQue (n <> 0) Faire
		Si (n > 0) Alors
			Positif := Positif + 1;
		Sinon
			Negatif := Negatif + 1;
		FinSi
		Lire(n);
	FinTantQue

	Ecrire("Le nombre des nombres positifs est: ", Positif);
	Ecrire("Le nombre des nombres négatifs est: ", Negatif);
Fin

Laisser des commentaires:

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :