Insérer un élément dans un tableau

Un algorithme qui permet d’insérer un élément dans un tableau:


Algorithmique Inserer;

Var	
	x, i, j: entier;
	T1[1..n], T2[1..n + 1]: entier;

Debut
	
	Lire(x);
	
	Pour i := 1 à n Faire
		T2[i] := T1[i];
	
	Pour i := 1 à n Faire
		Si ((T2[i] < x) Et (T2[i + 1] > x)) Alors
			T2[i + 1] := x;
			Pour j := (i + 2) à (n + 1) Faire
				T2[j] := T1[j - 1];
		FinSi
	
Fin

Autrement:


Algorithmique Inserer;

Var	
	x, i, j: entier;
	T1[1..n], T2[1..n + 1]: entier;

Debut
	
	Lire(x);
	i := 1;
	
	TantQue(T[i] < x) Faire
		T2[i] := T1[i];
		i := i + 1
	FinTantQue
	
	T2[i] := x;
	
	Pour j := (i + 1) à (n + 1) Faire
		T2[j] := T1[j - 1];
	
Fin

Laisser des commentaires:

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :