Comparer deux temps

Un algorithme qui permi de comparer deux temps et afficher le plus grand

On peut comparer heure par heure et minute par minute, mais on prefere cette solution…


Type
	heure: 0... 23;
	nimute: 0... 59;
	seconde: 0... 59;

	temps = Enregistrement
		H: heure;
		M: minute;
		S: secode;
	Fin;

Var
	T1, T2: temps;
	Dif: entier;

Debut

	Ecrire("Taper le 1re temps: ");
	Lire(T1.H, T1.M, T1.S);
	Ecrire("Taper le 2eme temps: ");
	Lire(T2.H, T2.M, T2.S);

	dif := (T1.H * 3600 + T1.M * 60 + T1.S) - (T2.H * 3600 + T2.M * 60 + T2.S);

	Si(dif > 0) Alors
		Ecrire("T1 grand...");
	Sinon Si(dif == 0) Alors
		Ecrire("Les deux sont égaux...")
	Sinon
		Ecrire("T2 grand...");
	FinSi

Fin.

2 commentaires

  1. Mohammed Fouad Dani · · Répondre

    merci bq pour cet algo mais dzl si faut🙂
    par exp: 1er temp 00:12:12 , 2eme temp 23:12:12
    dif=(00*3600+12*60+12)-(23*3600+12*60+12)
    dif=(732)-(83532)
    dif<0
    t2 grand !!

  2. Mohammed Fouad Dani · · Répondre

    Type
    heure: 0… 23;
    nimute: 0… 59;
    seconde: 0… 59;

    temps = Enregistrement
    H: heure;
    M: minute;
    S: secode;
    Fin;

    Var
    T1, T2: temps;
    Dif: entier;

    Debut

    Ecrire(« Taper le 1re temps: « );
    Lire(T1.H, T1.M, T1.S);
    Ecrire(« Taper le 2eme temps: « );
    Lire(T2.H, T2.M, T2.S);
    si(T1.H==00) alors
    T1.H==24;
    si(T2.H==00) alors
    T2.H==24;
    dif := (T1.H * 3600 + T1.M * 60 + T1.S) – (T2.H * 3600 + T2.M * 60 + T2.S);

    Si(dif > 0) Alors
    Ecrire(« T1 grand… »);
    Sinon Si(dif == 0) Alors
    Ecrire(« Les deux sont égaux… »)
    Sinon
    Ecrire(« T2 grand… »);
    FinSi

    Fin.

Laisser des commentaires:

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :