[Chaines de caractèrs] Transformer minuscule à majuscule

Un algo qui permit de transformer les minuscules à majuscules


Algorithmique Min2Maj;

Var
	i, j: entier;
	S[]: string:
	MAJ, MIN: tab[1... 26] en caractere

Debut
	MAJ = {'A', 'B', ... 'Z'};
	MIN = {'a', 'b', ... 'z'};

	Ecrire("Taper la phrase: ");
	Lire(S);
	Pour i := 1 à Length(S) Faire
		Pour j := 1 à 26 Faire
			Si(MIN[j] = S[i]) Alors
				S[i] := MAJ[j];
				j := 27; // Caser le boucle
			FinSi
		FinPour
	FinPour

Fin.

2 commentaires

  1. SniperHere · · Répondre

    salut,
    merci pour cet algorithme🙂
    j’ai une petite idée simple de transformer en maj ou min , la première idée se base sur la manipulation des bits on moduifiant le 5eme bit de la lettre. c a d on applique un masque avec le ET logique « & » pour modifier le 5eme bit. la deuxième idée se fait en ajoutant 32 au code ASCII en base décimale pour transformer en miniscule. et une soustraction de 32 pour le transformer en majiscule

  2. intéressant, merci
    MI BEJAIA

    — pour remplir le tableau en peux utilisé la boucle pour !

    k:=1;
    pour i:='a' a 'z' faire
      Min[k]:=i;
      k:=k+1;
    finpour;
    

Laisser des commentaires:

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :