[Pile] Implémentation une pile à l’aide d’un tableau

On va voir l’implémentation d’une pile à l’aide d’un tableau

  • InitPile: Initialiser une pile vide (libre)
  • SOM_P: Retourner le sommet d’une pile
  • Empiler: Insérer un élément au sommet d’une pile (Push)
  • Dépiler: Supprimer l’élément de sommet de la pile (Pop)
  • PileVide: Retourner Vrai si la pile est vide, sinon Faux

Algorithmique ImpPile;

type
	pile: tab[1... n];

Procédure InitPile(var P: pile, var SOM: entier);
	SOM := 0;
Fin;

Fonction SOM_P(var P: pile, var SOM: entier): entier;
	SOM_P := P[SOM];
Fin;

Procédure Empiler(var P: pile, var SOM: entier, x: entier);
	SI(SOM < n) Alors
		SOM := SOM + 1;
		P[SOM] := x;
	Sinon
		Ecrire("Empilement est impossible !")
	FinSi
Fin;

Procédure Dépiler(var P: pile, var SOM: entier);
	Si(SOM <> 0) Alors
		SOM := SOM - 1;
	Sinon
		Ecrire("Dépilement est impossible !")
	FinSi
Fin;

Fonction PileVide(P: pile, SOM: entier): bool;
	Si(SOM = 0) Alors
		PileVide := Vrai;
	Sinon
		PileVide := Faux;
	FinSi
Fin;

Laisser des commentaires:

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :